Elevated Linux worker queue times

Incident Report for Expo

Resolved

This incident has been resolved.
Posted Sep 05, 2026 - 00:10 PDT

Monitoring

The upstream issue with creating VM's has been resolved by GCP, Linux worker queues are draining, and queue times are returning to expected levels.
Posted Sep 04, 2026 - 13:38 PDT

Update

Queue times for Android builds and other Linux workflows are currently elevated due to upstream provider issues affecting the provisioning of VM's. GCP has confirmed the issue and is working on resolving.
Posted Sep 04, 2026 - 10:06 PDT

Identified

Queue times for Android builds and other Linux workflows are currently elevated due to GCP regional capacity constraints. We are currently enabling capacity in additional regions. Jobs in queue are continuing to progress.
Posted Sep 04, 2026 - 09:05 PDT