High queue times for Android and iOS builds

Incident Report for Expo

Resolved

This incident has been resolved.
Posted May 15, 2026 - 10:00 PDT

Monitoring

Android priority queue times have returned to normal levels and backlogged jobs are progressing. We are continuing to monitor performance.
Posted May 14, 2026 - 21:41 PDT

Investigating

Users with Android Builds on priority queues may experience extended wait times as we hit capacity
Posted May 14, 2026 - 15:32 PDT
This incident affected: Expo Application Services (EAS Build).