A fix was deployed at 2:50pm PT/5:50pm ET. The job queue has been running as expected.
The root cause of this incident is that a new version of a cache needed more vCPUs than it was given, and we have increased the CPU count as the immediate fix along with additional monitoring for CPU usage on these cache instances.
Posted Sep 02, 2026 - 15:05 PDT
Identified
We have determined that some of our package caches are under high load, and this is causing elevated build times and in turn causing higher Linux worker queue times. We are currently working on a fix. In-progress builds are continuing to complete and enqueued builds are continuing to be processed.
Posted Sep 02, 2026 - 14:52 PDT
Investigating
Queue times are elevated for Linux workers for EAS Build and Workflows. Android build jobs may be delayed. We are currently investigating the issue.
Posted Sep 02, 2026 - 14:44 PDT
This incident affected: Expo Application Services (EAS Build, EAS Workflows).