Major outage of EAS backend

Incident Report for Expo

Resolved

All services are back to operational.
Posted Jul 08, 2026 - 14:29 PDT

Update

We are continuing to monitor for any further issues.
Posted Jul 08, 2026 - 14:16 PDT

Update

We are continuing to monitor for any further issues.
Posted Jul 08, 2026 - 14:10 PDT

Monitoring

We implemented a fix. Systems are recovering. We will continue to monitor the situation until fully resolved.
Posted Jul 08, 2026 - 14:01 PDT

Investigating

We have detected a major outage of EAS services. We are actively working on resolving the issue.
Posted Jul 08, 2026 - 13:39 PDT
This incident affected: Expo Application Services (EAS Build, EAS Submit, EAS Update, EAS Insights, EAS Workflows, EAS Hosting) and Website.