Problems with API and website availability

Incident Report for Expo

Resolved

Our cloud provider's network is fully operational in all of the availability zones Expo uses.
Posted Sep 01, 2026 - 12:13 PDT

Monitoring

As of 10:06am PT we rescheduled our services to run outside of the affected availability zone that is still having some networking issues. In short, Expo's services are no longer affected but we are monitoring the cloud provider's own status updates until the incident is fully resolved and we can reschedule services across all availability zones again.
Posted Sep 01, 2026 - 10:30 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 01, 2026 - 09:16 PDT

Investigating

We are seeing problems in our cloud provider which cause API and website availability disruption on top of delays when processing GitHub events.
Posted Sep 01, 2026 - 08:51 PDT
This incident affected: Expo Application Services (EAS Build, EAS Submit, EAS Update, EAS Insights, EAS Workflows, EAS Hosting), Website, and Third-Party Services (Google Cloud Platform - Google Compute Engine).